Profile |  Login

We'd like to thank NAPAfrica for the information and samples provided below.

 

Configuration guidelines

 

Cisco Configuration Examples

no cdp run        
no service dhcp         
no ip bootp server        
no service config
        

 

This example assumes direct connection to the IX switch (i.e. No intermediate switch)  

 

        Interface GigabitEthernet0/1

        ip address x.x.x.x y.y.y.y

        ipv6 address x::y/64

        description PEERING:: IX_NAME

        no ip redirects

        no ip proxy-arp

        no cdp enable

        no ip directed-broadcast

        no mop enable

        no keepalive

        no ipv6 mld router

        no ipv6 mfib forwarding

        ipv6 nd suppress-ra (1)

        ipv6 nd ra suppress (2)

        ipv6 nd ra supress all (3)

        no ipv6 pim

        no ipv6 mld snooping

        ipv6 nd prefix default no-advertise     

    

        interface IFNAME

         ipv4 address 206.81.[ROUTER IP] 255.255.254.0

         ipv4 verify unicast source reachable-via any

         ipv4 unreachables disable

         arp timeout 14400

         ipv6 nd dad attempts 0

         ipv6 nd suppress-ra

         ipv6 nd reachable-time 14400000

 ipv6 verify unicast source reachable-via any

         ipv6 unreachables disable

         ipv6 address x::y/64

         lldp

         transmit disable

         !

         negotiation auto

 

 

If you are connecting to the IX via an intermediate Cisco switch, use the following configuration on the switch:

 

        vtp mode transparent

        no lldp run

        no cdp run

        Interface GigabitEthernet0/2

            description Link facing IX

            switchport access vlan 300

            switchport mode access

            switchport nonegotiate

            no keepalive

            no udld enable

            no cdp enable

            no lldp receive

            no lldp transmit

            spanning-tree bpdufilter enable

            end

        vlan 300

            name IX_NAME

        Interface GigabitEthernet0/1

            description Link facing my router

            switchport mode trunk

            switchport trunk allowed vlan 300

 

        no service dhcp

        no ip bootp server

        vtp mode transparent

        spanning-tree mode pvst

        spanning-tree extend system-id

        no spanning-tree vlan 300

        !

        vlan 300

         name IX_NAME

         exit

        !

        interface GigabitEthernet6/0/0

         description IX_NAME

         switchport access vlan 300

         switchport mode access

         switchport nonegotiate

         no mls qos trust

         no cdp enable

         spanning-tree bpdufilter enable

         exit

!

 

        set vtp mode off

        set port name /IfIdent/ IX_NAME

        set cdp disable /IfIdent/

        set udld disable /IfIdent/

        set trunk /IfIdent/ off dot1q

        set spantree bpdu-filter /IfIdent/ enable

        set vlan 300 name IX_NAME

        set vlan 300 /IfIdent

 

 

        Interface GigabitEthernet0/0

            description: Link facing intermediate switch

            no ip address

        Interface GigabitEthernet0/0.300

            ip address x.x.x.x y.y.y.y
            ipv6 address x::y/64        
            description PEERING:: IX_NAME
            no ip redirects
            no ip proxy-arp
            no cdp enable
            no ip directed-broadcast
            no mop enable
            no keepalive
            no ipv6 mld router
            no ipv6 mfib forwarding                     
            ipv6 nd suppress-ra (1)                     
            ipv6 nd ra suppress (2)
            ipv6 nd ra supress all (3)

no ipv6 pim                                       

            no ipv6 mld snooping

            ipv6 nd prefix default no-advertise

 

 

Brocade Configuration Examples

              

    vlan 300 name "IX_NAME" by port

    no spanning-tree

    untagged ethernet X/Y

 

    interface ethernet X/Y

     port-name "IX_NAME"

     route-only

     no spanning-tree

     ipv6 nd suppress-ra

     no vlan-dynamic-discovery

     ip address x.x.x.x y.y.y.y

     ipv6 address x::y/64

     no ip redirect

     no ipv6 redirect

     ip arp-age 120

 

Juniper Configuration Examples
 

set interfaces ae3 description "IX_NAME”

set interfaces ae3 mtu 9192

set interfaces ae3 aggregated-ether-options minimum-links 1

set interfaces ae3 aggregated-ether-options link-speed 10g

set interfaces ae3 aggregated-ether-options lacp active

set interfaces ae3 aggregated-ether-options lacp periodic fast

set interfaces ae3 aggregated-ether-options lacp link-protection disable

set interfaces ae3 aggregated-ether-options lacp link-protection revertive


set interfaces xe-x/x/x description "IX_NAME_AE3”

set interfaces xe-x/x/x gigether-options 802.3ad ae3

set interfaces xe-x/x/y description "IX_NAME_AE3”

set interfaces xe-x/x/y gigether-options 802.3ad ae3


set interfaces ae3 unit 0 bandwidth 20g

set interfaces ae3 unit 0 family inet sampling input

set interfaces ae3 unit 0 family inet sampling output

set interfaces ae3 unit 0 family inet address x.x.x.x/y

set interfaces ae3 unit 0 family inet no-redirects

set interfaces ae3 unit 0 family inet6 address x::y/64


OR
 

set interfaces xe-x/y/z unit 0 description "IX_NAME"

set interfaces xe-x/y/z unit 0 bandwidth 10g

set interfaces xe-x/y/z unit 0 family inet sampling input

set interfaces xe-x/y/z unit 0 family inet sampling output

set interfaces xe-x/y/z unit 0 family inet address x.x.x.x/y

set interfaces xe-x/y/z unit 0 family inet no-redirects

set interfaces xe-x/y/z unit 0 family inet6 address x::y/64


set protocols bgp group IX_NAME_LG type external

set protocols bgp group IX_NAME_LG neighbor x.x.x.1 description IX_NAME_LG

set protocols bgp group IX_NAME_LG peer-as {COLLECTOR_AS}

set protocols bgp group IX_NAME_LG neighbor x.x.x.1 local-address x.x.x.x

set protocols bgp group IX_NAME_LG neighbor x.x.x.1 import ROUTE_COLLECTOR_IN

set protocols bgp group IX_NAME_LG neighbor x.x.x.1 export EBGP-EXPORT-TJB

set protocols bgp group IX_NAME_LG neighbor x.x.x.1 remove-private

set protocols bgp group IX_NAME_RS type external

set protocols bgp group IX_NAME_RS peer-as {ROUTE_SERVER_AS}

set protocols bgp group IX_NAME_RS neighbor x.x.x.2 description IX_NAME_RS1

set protocols bgp group IX_NAME_RS neighbor x.x.x.2 local-address x.x.x.x

set protocols bgp group IX_NAME_RS neighbor x.x.x.2 import [ REJECT-BOGONMARTIAN IX_NAME_RS_IN ]

set protocols bgp group IX_NAME_RS neighbor x.x.x.2 family inet unicast prefix-limit maximum 100000

set protocols bgp group IX_NAME_RS neighbor x.x.x.2 export EBGP-EXPORT-TJB

set protocols bgp group IX_NAME_RS neighbor x.x.x.2 remove-private

set protocols bgp group IX_NAME_RS neighbor x.x.x.3 description IX_NAME_RS2

set protocols bgp group IX_NAME_RS neighbor x.x.x.3 local-address x.x.x.x

set protocols bgp group IX_NAME_RS neighbor x.x.x.3 import [ REJECT-BOGONMARTIAN IX_NAME_RS_IN ]

set protocols bgp group IX_NAME_RS neighbor x.x.x.3 family inet unicast prefix-limit maximum 100000

set protocols bgp group IX_NAME_RS neighbor x.x.x.3 export EBGP-EXPORT-TJB

set protocols bgp group IX_NAME_RS neighbor x.x.x.3 remove-private


set protocols bgp group IX_NAME_V6 type external

set protocols bgp group IX_NAME_V6 local-address x::y

set protocols bgp group IX_NAME_V6 export IX_NAME_v6_OUT

set protocols bgp group IX_NAME_V6 neighbor x::1 description IX_NAME_LG-v6

set protocols bgp group IX_NAME_V6 neighbor x::1 import ROUTE_COLLECTOR_IN

set protocols bgp group IX_NAME_V6 neighbor x::1 remove-private

set protocols bgp group IX_NAME_V6 neighbor x::1 peer-as {COLLECTOR_AS}

set protocols bgp group IX_NAME_V6 neighbor x::2 description IX_NAME_RS1_v6

set protocols bgp group IX_NAME_V6 neighbor x::2 import [ REJECT-BOGONMARTIAN IX_NAME_v6_IN ]

set protocols bgp group IX_NAME_V6 neighbor x::2 remove-private

set protocols bgp group IX_NAME_V6 neighbor x::2 peer-as {ROUTE_SERVER_AS}

set protocols bgp group IX_NAME_V6 neighbor x::3 description IX_NAME_RS2_v6

set protocols bgp group IX_NAME_V6 neighbor x::3 import [ REJECT-BOGONMARTIAN IX_NAME_v6_IN ]

set protocols bgp group IX_NAME_V6 neighbor x::3 remove-private

set protocols bgp group IX_NAME_V6 neighbor x::3 peer-as {ROUTE_SERVER_AS}


set policy-options policy-statement IX_NAME_v6_OUT term SELF from family inet6

set policy-options policy-statement IX_NAME_v6_OUT term SELF from protocol aggregate

set policy-options policy-statement IX_NAME_v6_OUT term SELF from route-filter {MY_PREFIXES} exact

set policy-options policy-statement IX_NAME_v6_OUT term SELF then accept

set policy-options policy-statement IX_NAME_v6_OUT term TRANSIT from family inet6

set policy-options policy-statement IX_NAME_v6_OUT term TRANSIT from community transit-cust-with-own-routes

set policy-options policy-statement IX_NAME_v6_OUT term TRANSIT from route-filter ::0/0 upto /48

set policy-options policy-statement IX_NAME_v6_OUT term TRANSIT then accept

set policy-options policy-statement IX_NAME_v6_OUT term REJECT-ALL-ELSE then reject


set policy-options policy-statement IX_NAME_v6_IN term RECEIVE-ALL from protocol bgp

set policy-options policy-statement IX_NAME_v6_IN term RECEIVE-ALL then community set ix-tjb

set policy-options policy-statement IX_NAME_v6_IN term RECEIVE-ALL then community add ix_peer

set policy-options policy-statement IX_NAME_v6_IN term RECEIVE-ALL then accept


set policy-options policy-statement REJECT-BOGONMARTIAN term OWN_PREFIXES from route-filter {MY_PREFIXES} orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term OWN_PREFIXES from route-filter {MY_PREFIXES} orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term OWN_PREFIXES then reject

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from family inet

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from route-filter 0.0.0.0/0 exact

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from route-filter 0.0.0.0/8 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from route-filter 10.0.0.0/8 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from route-filter 100.64.0.0/10 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from route-filter 127.0.0.0/8 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from route-filter 169.254.0.0/16 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from route-filter 172.16.0.0/12 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from route-filter 192.0.0.0/24 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from route-filter 192.0.2.0/24 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from route-filter 192.88.99.0/24 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from route-filter 192.168.0.0/16 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from route-filter 198.18.0.0/15 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from route-filter 198.51.100.0/24 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from route-filter 203.0.113.0/24 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS from route-filter 224.0.0.0/4 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v4_MARTIANS then reject

set policy-options policy-statement REJECT-BOGONMARTIAN term v6_MARTIANS from family inet6

set policy-options policy-statement REJECT-BOGONMARTIAN term v6_MARTIANS from route-filter 3ffe::/16 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v6_MARTIANS from route-filter 0000::/8 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v6_MARTIANS from route-filter 2001:db8::/32 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v6_MARTIANS from route-filter 2001::/32 exact next policy

set policy-options policy-statement REJECT-BOGONMARTIAN term v6_MARTIANS from route-filter 2001::/32 longer

set policy-options policy-statement REJECT-BOGONMARTIAN term v6_MARTIANS from route-filter 2002::/16 exact next policy

set policy-options policy-statement REJECT-BOGONMARTIAN term v6_MARTIANS from route-filter 2002::/16 longer

set policy-options policy-statement REJECT-BOGONMARTIAN term v6_MARTIANS from route-filter fe00::/9 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v6_MARTIANS from route-filter ff00::/8 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v6_MARTIANS from route-filter 2000::/3 prefix-length-range /49-/128

set policy-options policy-statement REJECT-BOGONMARTIAN term v6_MARTIANS from route-filter 0::/0 orlonger

set policy-options policy-statement REJECT-BOGONMARTIAN term v6_MARTIANS then reject

set policy-options policy-statement REJECT-BOGONMARTIAN then next policy


set policy-options policy-statement IX_NAME_RS_IN term RECEIVE-ALL from protocol bgp

set policy-options policy-statement IX_NAME_RS_IN term RECEIVE-ALL then metric 0

set policy-options policy-statement IX_NAME_RS_IN term RECEIVE-ALL then local-preference 105

set policy-options policy-statement IX_NAME_RS_IN term RECEIVE-ALL then community set ix-tjb

set policy-options policy-statement IX_NAME_RS_IN term RECEIVE-ALL then community add ix_peer

set policy-options policy-statement IX_NAME_RS_IN term RECEIVE-ALL then accept


set policy-options policy-statement ROUTE_COLLECTOR_IN term REJECT-ALL then reject


set policy-options policy-statement EBGP-EXPORT-TJB term OWN_SUPERNET from community own_aggregate_supernet-tjb

set policy-options policy-statement EBGP-EXPORT-TJB term OWN_SUPERNET then accept

set policy-options policy-statement EBGP-EXPORT-TJB term TRANSIT-CUST-PREFIXES from community transit-cust-with-own-routes

set policy-options policy-statement EBGP-EXPORT-TJB term TRANSIT-CUST-PREFIXES then accept

set policy-options policy-statement EBGP-EXPORT-TJB term MANUAL-PREFIX-LIST from route-filter w.x.y.0/22 exact

set policy-options policy-statement EBGP-EXPORT-TJB term MANUAL-PREFIX-LIST then accept

set policy-options policy-statement EBGP-EXPORT-TJB term REJECT-ALL-ELSE then reject


set policy-options community ix_peer members ASN:nnnnn

set policy-options community transit-cust-with-own-routes members ASN:nnnnn

set policy-options community ix-tjb members ASN:nnnnn

set policy-options community own_aggregate_supernet-tjb members ASN:nnnnn



 

Mikrotik Configuration Examples
 

/interface ethernet set {if_name} comment="IX_NAME"

/ip neighbor discovery set {if_name} discover=no

/ip address add interface={if_name} address=x.x.x.x/y

/ipv6 address add interface={if_name} address=x::y/64 advertise=no

/tool romon port disable numbers=n


/routing bgp instance

set default as={MY_ASN} redistribute-other-bgp=yes

/ip address

add address=x.x.x.x/y interface="{if_name}" network=x.x.x.x

/ipv6 address

add address=x::y/64 advertise=no interface="{if_name}"

/routing bgp network

add network=x.x.x.x/y synchronize=no

add network=x::/y synchronize=no


/routing bgp peer

add in-filter=EBGP_V4_IN max-prefix-limit=1 name=IX_NAME_V4_LG out-filter=EBGP_V4_OUT remote-address=x.x.x.x remote-as={IX_NAME_LG_ASN} ttl=default

add address-families=ipv6 in-filter=EBGP_V6_IN max-prefix-limit=1 name=IX_NAME_V6_LG out-filter=EBGP_V6_OUT remote-address=x::y remote-as={IX_NAME_LG_ASN} ttl=default

add in-filter=EBGP_V4_IN max-prefix-limit=100000 name=NAP_JHB_IPv4_RS1 out-filter=NAP_JHB_IPv4_OUT remote-address=196.60.9.2 remote-as=37195 ttl=default

add in-filter=EBGP_V4_IN max-prefix-limit=100000 name=NAP_JHB_IPv4_RS2 out-filter=NAP_JHB_IPv4_OUT remote-address=196.60.9.3 remote-as=37195 ttl=default

add address-families=ipv6 in-filter=NAP_JHB_IPv6_IN max-prefix-limit=50000 name=NAP_JHB_IPv6_RS1 out-filter=NAP_JHB_IPv6_OUT remote-address=2001:43f8:6d0::2 remote-as=37195 ttl=default

add address-families=ipv6 in-filter=NAP_JHB_IPv6_IN max-prefix-limit=50000 name=NAP_JHB_IPv6_RS2 out-filter=NAP_JHB_IPv6_OUT remote-address=2001:43f8:6d0::3 remote-as=37195 ttl=default

add in-filter=EBGP_V4_IN max-prefix-limit=500 name=Cloudflare_IPv4 out-filter=NAP_JHB_IPv4_OUT remote-address=196.60.8.198 remote-as=13335 ttl=default

add address-families=ipv6 in-filter=NAP_JHB_IPv6_IN max-prefix-limit=100 name=Cloudflare_IPv6 out-filter=NAP_JHB_IPv6_OUT remote-address=2001:43f8:6d0::198 remote-as=13335 ttl=default


/routing filter

add action=accept chain=EBGP_V4_OUT prefix={OWN_PREFIXES} prefix-length={MORE_SPECIFICS} protocol=bgp

add action=accept chain=EBGP_V4_OUT prefix={DOWNSTREAM_PREFIXES} prefix-length={MORE_SPECIFICS} protocol=bgp

add action=discard chain=EBGP_V4_OUT


add action=accept chain=EBGP_V6_OUT prefix={OWN_PREFIXES} prefix-length={MORE_SPECIFICS} protocol=bgp

add action=accept chain=EBGP_V6_OUT prefix={DOWNSTREAM_PREFIXES} prefix-length={MORE_SPECIFICS} protocol=bgp

add action=discard chain=EBGP_V6_OUT


add action=discard chain=EBGP_V4_IN prefix=127.0.0.0/8 prefix-length=8-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix=10.0.0.0/8 prefix-length=8-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix=169.254.0.0/16 prefix-length=16-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix=172.16.0.0/12 prefix-length=12-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix=192.168.0.0/16 prefix-length=16-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix=100.64.0.0/10 prefix-length=10-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix=192.0.0.0/24 prefix-length=24-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix=192.0.2.0/24 prefix-length=24-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix=198.51.100.0/24 prefix-length=24-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix=198.18.0.0/15 prefix-length=15-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix=198.51.100.0/24 prefix-length=24-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix=203.0.113.0/24 prefix-length=24-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix=224.0.0.0/4 prefix-length=4-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix=240.0.0.0/4 prefix-length=4-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix=255.255.255.255 prefix-length=4-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix-length=25-32 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix=0.0.0.0/0 protocol=bgp

add action=discard chain=EBGP_V4_IN prefix={OWN_PREFIXES} prefix-length={MORE_SPECIFICS} protocol=bgp

add action=discard chain=EBGP_V4_IN prefix={DOWNSTREAM_PREFIXES} prefix-length={MORE_SPECIFICS} protocol=bgp

add action=accept chain=EBGP_V4_IN prefix-length=0-24 protocol=bgp set-bgp-communities=”{YOUR_COMMUNITIES}” set-bgp-local-pref={YOUR_LOCAL_PREF}

 

Mikrotik IPv6

 

/routing filter

add action=discard protocol=bgp chain=EBGP_V6_IN prefix=3ffe::/16 prefix-length=0-128

add action=discard protocol=bgp chain=EBGP_V6_IN prefix=2001:db8::/32 prefix-length=0-128

add action=accept protocol=bgp chain=EBGP_V6_IN prefix=2001::/32

add action=discard protocol=bgp chain=EBGP_V6_IN prefix=2001::/32 prefix-length=0-128

add action=accept protocol=bgp chain=EBGP_V6_IN prefix=2002::/16

add action=discard protocol=bgp chain=EBGP_V6_IN prefix=2002::/16 prefix-length=0-128

add action=discard protocol=bgp chain=EBGP_V6_IN prefix=::/8 prefix-length=0-128

add action=discard protocol=bgp chain=EBGP_V6_IN prefix=fe00::/9 prefix-length=0-128

add action=discard protocol=bgp chain=EBGP_V6_IN prefix=ff00::/8 prefix-length=0-128

add action=discard protocol=bgp chain=EBGP_V6_IN prefix={OWN_PREFIXES} prefix-length={MORE_SPECIFICS}

add action=discard protocol=bgp chain=EBGP_V6_IN prefix={DOWNSTREAM_PREFIXES} prefix-length={MORE_SPECIFICS}

add action=accept protocol=bgp chain=EBGP_V6_IN prefix=2000::/3 prefix-length=0-48 set-bgp-communities=”{YOUR_COMMUNITIES}” set-bgp-local-pref={YOUR_LOCAL_PREF}

add action=discard protocol=bgp chain=EBGP_V6_IN prefix=::/0 prefix-length=0-128

add action=discard protocol=bgp chain=EBGP_V6_IN

 

 

Arista Configuration Examples

           

    no ip multicast-routing

 

    vlan 300

        name IX_NAME

 

    interface ethernetY

        description IX_NAME

        switchport access vlan 300

        arp timeout 7200

        ipv6 enable

        ipv6 nd ra suppress all

        no lldp transmit

        no ntp serve

        spanning-tree bpdufilter enable

 

    interface ethernetY

        no switchport

        description IX_NAME

        ipv6 enable

        ipv6 nd ra suppress all

        no lldp transmit

        no ntp serve

        ip address x.x.x.x y.y.y.y

        ipv6 address x::y/64

        arp timeout 7200

        no lldp transmit

        no ip pim

 

        ip prefix-list BOGONSIPv4 seq 10 deny 0.0.0.0/8 le 32

        ip prefix-list BOGONSIPv4 seq 20 deny 10.0.0.0/8 le 32

        ip prefix-list BOGONSIPv4 seq 30 deny 100.64.0.0/10 le 32

        ip prefix-list BOGONSIPv4 seq 40 deny 127.0.0.0/8 le 32

        ip prefix-list BOGONSIPv4 seq 50 deny 169.254.0.0/16 le 32

        ip prefix-list BOGONSIPv4 seq 60 deny 172.16.0.0/12 le 32

        ip prefix-list BOGONSIPv4 seq 70 deny 192.0.0.0/24 le 32

        ip prefix-list BOGONSIPv4 seq 80 deny 192.0.2.0/24 le 32

        ip prefix-list BOGONSIPv4 seq 90 deny 192.168.0.0/16 le 32

        ip prefix-list BOGONSIPv4 seq 100 deny 198.18.0.0/15 le 32

        ip prefix-list BOGONSIPv4 seq 110 deny 198.51.100.0/24 le 32

        ip prefix-list BOGONSIPv4 seq 120 deny 203.0.113.0/24 le 32

        ip prefix-list BOGONSIPv4 seq 130 deny 224.0.0.0/3 le 32

        ip prefix-list BOGONSIPv4 seq 9999 permit 0.0.0.0/0 le 24


        ipv6 prefix-list BOGONSIPv6 deny 3ffe::/16 le 128

        ipv6 prefix-list BOGONSIPv6 deny 2001:db8::/32 le 128

        ipv6 prefix-list BOGONSIPv6 permit 2001::/32

        ipv6 prefix-list BOGONSIPv6 deny 2001::/32 le 128

        ipv6 prefix-list BOGONSIPv6 permit 2002::/16

        ipv6 prefix-list BOGONSIPv6 deny 2002::/16 le 128

        ipv6 prefix-list BOGONSIPv6 deny 0000::/8 le 128

        ipv6 prefix-list BOGONSIPv6 deny fe00::/9 le 128

        ipv6 prefix-list BOGONSIPv6 deny ff00::/8 le 128

        ipv6 prefix-list BOGONSIPv6 permit 2000::/3 le 48

        ipv6 prefix-list BOGONSIPv6 deny 0::/0 le 128


        ip prefix-list MY_V4_PREFIXES seq 10 permit x.x.x.x/y eq/le/ge n

        ip prefix-list DOWNSTREAM_V4_PREFIXES seq 10 permit x.x.x.x/y eq/le/ge n


        ipv6 prefix-list MY_V6_PREFIXES permit x::/y eq/le/ge n

        ipv6 prefix-list DOWNSTREAM_V6_PREFIXES permit x::/y eq/le/ge n

 

        route-map EBGP_V4_OUT permit 10

            match ip address prefix-list MY_V4_PREFIXES

            set community A:N

        route-map EBGP_V4_OUT permit 20

            match ip address prefix-list DOWNSTREAM_V4_PREFIXES

            set community A:N


        route-map EBGP_V6_OUT permit 10

            match ipv6 address prefix-list MY_V6_PREFIXES

            set community A:N

        route-map EBGP_V6_OUT permit 20

            match ipv6 address prefix-list DOWNSTREAM_V6_PREFIXES

            set community A:N

    

        route-map IX_NAME_V4_IN deny 10

            match ip address prefix-list BOGONSIPv4


        route-map IX_NAME_V4_IN permit 20

            set local-preference {YOUR_LOCAL_PREF}

            set community A:N


        route-map IX_NAME_V6_IN deny 10

            match ip address prefix-list BOGONSIPv6


        route-map IX_NAME_V6_IN permit 20

            set local-preference {YOUR_LOCAL_PREF}

            set community A:N

 

~

 

router-id x.x.x.x

network x.x.x.x/y

        neighbor IX_NAME_V4 peer-group

        neighbor IX_NAME_V4 remove-private-as all

        neighbor IX_NAME_V4 local-v4-addr 196.10.140.39

        neighbor IX_NAME_V4 route-map IX_NAME_V4_IN in

        neighbor IX_NAME_V4 route-map IX_NAME_V4_OUT out

        neighbor IX_NAME_V4 send-community

        neighbor IX_NAME_V4 maximum-routes 12000

        neighbor IX_NAME_V4 graceful-restart

        neighbor IX_NAME_V4 soft-reconfiguration inbound all



        neighbor IX_NAME_V6 peer-group

        neighbor IX_NAME_V6 remove-private-as all

        neighbor IX_NAME_V6 route-map IX_NAME_V6_IN in

        neighbor IX_NAME_V6 route-map IX_NAME_V6_OUT out

        neighbor IX_NAME_V6 send-community

        neighbor IX_NAME_V6 maximum-routes 12000

        neighbor IX_NAME_V6 graceful-restart

        neighbor IX_NAME_V6 soft-reconfiguration inbound all



        neigh x.x.x.y peer-group IX_NAME_V4

        neigh x.x.x.y remote-as {PEER_ASN}

        neigh x.x.x.y description DESCRIPTION



        neigh x::y peer-group IX_NAME_V6

        neigh x::y remote-as {PEER_ASN}

        neigh x::y description IX_NAME_ROUTE_SERVER

        no neighbor x::y enforce-first-as



        address-family ipv4

        neighbor IX_NAME_V4 activate

         !

        address-family ipv6

        neighbor IX_NAME_V6 activate